<!DOCTYPE html>
<html lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head>
<meta charset="UTF-8" />
<!-- <script src="//cdn.optimizely.com/js/4040009.js"></script> -->
<title>Fixing Bluetooth problem with TP-Link UB400 | Martin Tod</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="stylesheet" href="https://www.martintod.org.uk/?w3tc_minify=507ee.css" media="all" />

<link rel="pingback" href="https://www.martintod.org.uk/xmlrpc.php" />

<!-- All In One SEO Pack 3.4.3[197,260] -->
<meta name="description"  content="I recently bought myself some Sony Bluetooth earbuds for my phone, but I was keen to see if I could connect them to my PC too - so that I could use them in" />

<meta name="keywords"  content="bluetooth,tp-link,ub400,windows 10,audio,technology" />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.martintod.org.uk/#organization","url":"https://www.martintod.org.uk/","name":"Martin Tod","sameAs":[]},{"@type":"WebSite","@id":"https://www.martintod.org.uk/#website","url":"https://www.martintod.org.uk/","name":"Martin Tod","publisher":{"@id":"https://www.martintod.org.uk/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.martintod.org.uk/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/#webpage","url":"https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/","inLanguage":"en-GB","name":"Fixing Bluetooth problem with TP-Link UB400","isPartOf":{"@id":"https://www.martintod.org.uk/#website"},"breadcrumb":{"@id":"https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/#breadcrumblist"},"datePublished":"2020-06-28T15:28:50+01:00","dateModified":"2020-06-28T15:29:27+01:00"},{"@type":"Article","@id":"https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/#article","isPartOf":{"@id":"https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/#webpage"},"author":{"@id":"https://www.martintod.org.uk/author/admin/#author"},"headline":"Fixing Bluetooth problem with TP-Link UB400","datePublished":"2020-06-28T15:28:50+01:00","dateModified":"2020-06-28T15:29:27+01:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/#webpage"},"publisher":{"@id":"https://www.martintod.org.uk/#organization"},"articleSection":"Audio, Technology, Bluetooth, TP-Link, UB400, Windows 10"},{"@type":"Person","@id":"https://www.martintod.org.uk/author/admin/#author","name":"Martin","sameAs":[],"image":{"@type":"ImageObject","@id":"https://www.martintod.org.uk/#personlogo","url":"https://secure.gravatar.com/avatar/12da19254cb76e475a13c29961a7289b?s=96&d=mm&r=g","width":96,"height":96,"caption":"Martin"}},{"@type":"BreadcrumbList","@id":"https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.martintod.org.uk/","url":"https://www.martintod.org.uk/","name":"Martin Tod"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/","url":"https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/","name":"Fixing Bluetooth problem with TP-Link UB400"}}]}]}</script>
<link rel="canonical" href="https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/" />
<!-- All In One SEO Pack -->
<link rel='dns-prefetch' href='//www.martintod.org.uk' />
<link rel='dns-prefetch' href='//ssl.p.jwpcdn.com' />
<link rel='dns-prefetch' href='//maps.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Martin Tod &raquo; Feed" href="https://www.martintod.org.uk/feed/" />
<link rel="alternate" type="application/rss+xml" title="Martin Tod &raquo; Comments Feed" href="https://www.martintod.org.uk/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Martin Tod &raquo; Fixing Bluetooth problem with TP-Link UB400 Comments Feed" href="https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.martintod.org.uk\/wp-includes\/js\/wp-emoji-release.min.js?ver=ba93174f25df77d8829ca6586d356f70"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel="stylesheet" href="https://www.martintod.org.uk/?w3tc_minify=07956.css" media="all" />
















<script type='text/javascript' src='https://martintod.s3.amazonaws.com/wp-includes/js/jquery/jquery.js.gzip?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://martintod.s3.amazonaws.com/wp-includes/js/jquery/jquery-migrate.min.js.gzip?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.martintod.org.uk/wp-content/plugins/rotatingtweets/js/jquery.cycle2.renamed.js?ver=1.9.9'></script>
<script type='text/javascript' src='https://www.martintod.org.uk/wp-content/plugins/rotatingtweets/js/jquery.cycle2.scrollVert.renamed.js?ver=1.9.9'></script>
<script type='text/javascript' src='https://www.martintod.org.uk/wp-content/plugins/rotatingtweets/js/jquery.cycle2.carousel.renamed.js?ver=1.9.9'></script>
<script type='text/javascript' src='https://www.martintod.org.uk/wp-content/plugins/rotatingtweets/js/rotatingtweets_v2.js?ver=1.9.9'></script>
<script type='text/javascript' src='https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/js/wm2-support.js.gzip?ver=ba93174f25df77d8829ca6586d356f70'></script>
<script type='text/javascript' src='https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/js/jquery.lightbox-0.5.min.js.gzip?ver=0.5'></script>
<script type='text/javascript' src='https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/js/wm2.lightbox.js.gzip?ver=ba93174f25df77d8829ca6586d356f70'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cforms2_ajax = {"url":"https:\/\/www.martintod.org.uk\/wp-admin\/admin-ajax.php","nonces":{"submitcform":"5d495b35e3"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.martintod.org.uk/wp-content/plugins/cforms2/js/cforms.js?ver=15.0.3'></script>
<script type='text/javascript' src='https://ssl.p.jwpcdn.com/6/12/jwplayer.js?ver=ba93174f25df77d8829ca6586d356f70'></script>
<script type='text/javascript' src='https://www.martintod.org.uk/wp-content/plugins/wp-geo/js/tooltip.js?ver=3.5.1'></script>
<script type='text/javascript' src='https://www.martintod.org.uk/wp-content/plugins/wp-geo/js/wp-geo.v3.js?ver=3.5.1'></script>
<script type='text/javascript' src='//maps.googleapis.com/maps/api/js?language=en-GB&key=AIzaSyApHu4P5aWe6B151OcoSk_7aOTeOOBstPs&ver=3.5.1'></script>
<script type='text/javascript' src='https://martintod.s3.amazonaws.com/wp-includes/js/swfobject.js.gzip?ver=2.2-20120417'></script>
<script type='text/javascript' src='https://www.martintod.org.uk/index.php?wordtube-js=true&#038;ver=2.0'></script>
<script type='text/javascript' src='https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/js/jquery.cycle.js.gzip?ver=2.22'></script>
<script type='text/javascript' src='https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/js/wm.image.cycle.js.gzip?ver=1.0'></script>
<script type='text/javascript' src='https://www.martintod.org.uk/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.martintod.org.uk/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.martintod.org.uk/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.martintod.org.uk/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='COVID-19 and our local streets' href='https://www.martintod.org.uk/2020/05/04/covid-19-and-our-local-streets/' />

<link rel='shortlink' href='https://www.martintod.org.uk/?p=2122' />
<link rel="alternate" type="application/json+oembed" href="https://www.martintod.org.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.martintod.org.uk%2F2020%2F06%2F28%2Ffixing-bluetooth-problem-with-tp-link-ub400%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.martintod.org.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.martintod.org.uk%2F2020%2F06%2F28%2Ffixing-bluetooth-problem-with-tp-link-ub400%2F&#038;format=xml" />
<meta http-equiv="X-Clacks-Overhead" content="GNU Terry Pratchett" /><script type="text/javascript">jwplayer.defaults = { "ph": 2 };</script>
            <script type="text/javascript">
            if (typeof(jwp6AddLoadEvent) == 'undefined') {
                function jwp6AddLoadEvent(func) {
                    var oldonload = window.onload;
                    if (typeof window.onload != 'function') {
                        window.onload = func;
                    } else {
                        window.onload = function() {
                            if (oldonload) {
                                oldonload();
                            }
                            func();
                        }
                    }
                }
            }
            </script>

            <meta property="og:title" content="Fixing Bluetooth problem with TP-Link UB400"/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/"/>
<meta property="og:site_name" content="Martin Tod"/>
<meta property="fb:page_id" content="on"/>
<style id="ctcc-css" type="text/css" media="screen">
				#catapult-cookie-bar {
					box-sizing: border-box;
					max-height: 0;
					opacity: 0;
					z-index: 99999;
					overflow: hidden;
					color: #ddd;
					position: fixed;
					left: 0;
					top: 0;
					width: 100%;
					background-color: #464646;
				}
				#catapult-cookie-bar a {
					color: #fff;
				}
				#catapult-cookie-bar .x_close span {
					background-color: ;
				}
				button#catapultCookie {
					background:;
					color: ;
					border: 0; padding: 6px 9px; border-radius: 3px;
				}
				#catapult-cookie-bar h3 {
					color: #ddd;
				}
				.has-cookie-bar #catapult-cookie-bar {
					opacity: 1;
					max-height: 999px;
					min-height: 30px;
				}</style><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.martintod.org.uk/?wordfence_lh=1&hid=840C94B2562D9C7384A35863C33301E9');
</script>
			<script type="text/javascript">
			//<![CDATA[

			// WP Geo default settings
			var wpgeo_w = '100%';
			var wpgeo_h = '300px';
			var wpgeo_type = 'G_NORMAL_MAP';
			var wpgeo_zoom = 5;
			var wpgeo_controls = 'GLargeMapControl3D';
			var wpgeo_controltypes = 'G_NORMAL_MAP,G_SATELLITE_MAP,G_HYBRID_MAP,G_PHYSICAL_MAP';
			var wpgeo_scale = 'N';
			var wpgeo_overview = 'N';

			//]]>
			</script>
			
			<script type="text/javascript">
			//<![CDATA[
			// ----- WP Geo Marker Icons -----
			var wpgeo_icon_large = wpgeo_createIcon(20, 34, 10, 34, 'https://martintod.s3.amazonaws.com/wp-content/uploads/wp-geo/markers/large-marker.png', 'https://martintod.s3.amazonaws.com/wp-content/uploads/wp-geo/markers/large-marker-shadow.png');var wpgeo_icon_small = wpgeo_createIcon(10, 17, 5, 17, 'https://martintod.s3.amazonaws.com/wp-content/uploads/wp-geo/markers/small-marker.png', 'https://martintod.s3.amazonaws.com/wp-content/uploads/wp-geo/markers/small-marker-shadow.png');var wpgeo_icon_dot = wpgeo_createIcon(8, 8, 3, 6, 'https://martintod.s3.amazonaws.com/wp-content/uploads/wp-geo/markers/dot-marker.png', 'https://martintod.s3.amazonaws.com/wp-content/uploads/wp-geo/markers/dot-marker-shadow.png');
			//]]>
			</script>
			<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = ['mp3','pdf'];
    var analyticsSnippet = 'disabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-259652-2', 'auto');
	ga('require', 'linkid', 'linkid.js');
 
	ga('send', 'pageview');
</script>

<!-- START - Open Graph and Twitter Card Tags 2.3.3 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_GB"/>
  <meta property="og:site_name" content="Martin Tod"/>
  <meta property="og:title" content="Fixing Bluetooth problem with TP-Link UB400"/>
  <meta property="og:url" content="https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/"/>
  <meta property="og:type" content="article"/>
  <meta property="og:description" content="I recently bought myself some Sony Bluetooth earbuds for my phone, but I was keen to see if I could connect them to my PC too - so that I could use them in conference calls, for example.



But my computer didn&#039;t have Bluetooth. So I bought TP-Link UB400 Bluetooth Adaptor online, because I&#039;ve used a"/>
  <meta property="og:image" content="https://martintod.s3.amazonaws.com/wp-content/uploads/2017/10/WebsiteMeonValleyPhoto1200630.jpg"/>
  <meta property="og:image:url" content="https://martintod.s3.amazonaws.com/wp-content/uploads/2017/10/WebsiteMeonValleyPhoto1200630.jpg"/>
  <meta property="og:image:secure_url" content="https://martintod.s3.amazonaws.com/wp-content/uploads/2017/10/WebsiteMeonValleyPhoto1200630.jpg"/>
  <meta property="article:published_time" content="2020-06-28T16:28:50+01:00"/>
  <meta property="article:modified_time" content="2020-06-28T16:29:27+01:00" />
  <meta property="og:updated_time" content="2020-06-28T16:29:27+01:00" />
  <meta property="article:section" content="Audio"/>
  <meta property="article:section" content="Technology"/>
 <!-- Google+ / Schema.org -->
  <meta itemprop="name" content="Fixing Bluetooth problem with TP-Link UB400"/>
  <meta itemprop="headline" content="Fixing Bluetooth problem with TP-Link UB400"/>
  <meta itemprop="description" content="I recently bought myself some Sony Bluetooth earbuds for my phone, but I was keen to see if I could connect them to my PC too - so that I could use them in conference calls, for example.



But my computer didn&#039;t have Bluetooth. So I bought TP-Link UB400 Bluetooth Adaptor online, because I&#039;ve used a"/>
  <meta itemprop="image" content="https://martintod.s3.amazonaws.com/wp-content/uploads/2017/10/WebsiteMeonValleyPhoto1200630.jpg"/>
  <meta itemprop="datePublished" content="2020-06-28"/>
  <meta itemprop="dateModified" content="2020-06-28T16:29:27+01:00" />
  <meta itemprop="author" content="Martin"/>
  <!--<meta itemprop="publisher" content="Martin Tod"/>--> <!-- To solve: The attribute publisher.itemtype has an invalid value -->
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="Fixing Bluetooth problem with TP-Link UB400"/>
  <meta name="twitter:url" content="https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/"/>
  <meta name="twitter:description" content="I recently bought myself some Sony Bluetooth earbuds for my phone, but I was keen to see if I could connect them to my PC too - so that I could use them in conference calls, for example.



But my computer didn&#039;t have Bluetooth. So I bought TP-Link UB400 Bluetooth Adaptor online, because I&#039;ve used a"/>
  <meta name="twitter:image" content="https://martintod.s3.amazonaws.com/wp-content/uploads/2017/10/WebsiteMeonValleyPhoto1200630.jpg"/>
  <meta name="twitter:card" content="summary_large_image"/>
  <meta name="twitter:site" content="@mpntod"/>
 <!-- SEO -->
 <!-- Misc. tags -->
 <!-- is_singular -->
<!-- END - Open Graph and Twitter Card Tags 2.3.3 -->
	
</head>

<body class="post-template-default single single-post postid-2122 single-format-standard">
<div id="wrapper" class="hfeed">
	<div id="header">
		<div id="masthead">
			<div id="branding" role="banner">
				<div id="wm-line-box"></div>
				<div id="wm-title-box">
					<div id="wm-site-title">
						<a href="https://www.martintod.org.uk/" title="Martin Tod" rel="home"  >/Martin Tod</a>
					</div>
					<div id="wm-site-description-box" 
 class='wm-site-desc-box-bird' >
						<div id="wm-site-description"  class='wm-site-desc-box-bird' ><p class="wm-site-desc-text">A believer in progress, material and social</p></div>
					</div>
				</div>
				<div id="wm-header-logo-box">
				<a href='https://www.libdems.org.uk/join_us.aspx?Ref=632'>				<img id="wm-header-logo" title="Join the Liberal Democrats" src="https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/ldlogo.gif" alt="Lib Dem logo" width="81" height="61" /></a>
				</div>
				</div><!-- #branding -->

			<div id="access" role="navigation">
			  				<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">Skip to content</a></div>
								<div class="menu-header"><ul id="menu-test-menu" class="menu"><li id="menu-item-814" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-814">/<a href="http://www.martintod.org.uk/">Home</a></li>
<li id="menu-item-815" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-815">/<a href="https://www.martintod.org.uk/about/">About Martin</a></li>
<li id="menu-item-1020" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1020">/<a href="https://www.martintod.org.uk/map/">Activity Map</a></li>
<li id="menu-item-820" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-820">/<a href="https://www.martintod.org.uk/video/">Video</a>
<ul class="sub-menu">
	<li id="menu-item-1710" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1710">/<a href="https://www.martintod.org.uk/video/hampshire-county-council-videos/">Hampshire County Council videos</a></li>
	<li id="menu-item-1029" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1029">/<a href="https://www.martintod.org.uk/ads/">Ads</a></li>
	<li id="menu-item-1308" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1308">/<a href="https://www.martintod.org.uk/video/">TV Appearances</a></li>
</ul>
</li>
<li id="menu-item-853" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-853">/<a href="https://www.martintod.org.uk/martinsblog/">Blog</a></li>
<li id="menu-item-821" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-821">/<a href="https://www.martintod.org.uk/contact-martin/">Contact</a></li>
</ul></div>			</div><!-- #access -->
			
			             	<div id="s1" style="width:801px;height:200px;overflow:hidden;margin-bottom:20px;">
               		            	 		<div style="background:url(http://farm5.static.flickr.com/4063/4441427256_8a5f535703_o.jpg ) center center;width:801px;height:200px"></div>

            	 		            	 		<div style="background:url(http://farm5.static.flickr.com/4007/4440849201_a759f32907_o.jpg ) center center;width:801px;height:200px"></div>

            	 		            	 		<div style="background:url(http://farm5.static.flickr.com/4062/4443705861_12d1377e68_o.jpg ) center center;width:801px;height:200px"></div>

            	 		            	 		<div style="background:url(http://farm5.static.flickr.com/4038/4440808941_7160b8d2eb_o.jpg ) center center;width:801px;height:200px"></div>

            	 		            	 		<div style="background:url(http://farm3.static.flickr.com/2698/4443876755_0bdf16c5b4_o.jpg ) center center;width:801px;height:200px"></div>

            	 		            	 		<div style="background:url(http://farm5.static.flickr.com/4017/4441671140_7b08ab5469_o.jpg ) center center;width:801px;height:200px"></div>

            	 		            	 		<div style="background:url(http://farm5.static.flickr.com/4015/4440925357_f3b0762ea2_o.jpg ) center center;width:801px;height:200px"></div>

            	 		            	 		<div style="background:url(http://farm5.static.flickr.com/4034/4443794611_31959f20b1_o.jpg ) center center;width:801px;height:200px"></div>

            	 		               	</div>
               		</div><!-- #masthead -->
	</div><!-- #header -->

	<div id="main">
		<div id="container">
			<div id="content" role="main">

			

				<div id="nav-above" class="navigation">
					<div class="nav-previous"><a href="https://www.martintod.org.uk/2020/05/04/covid-19-and-our-local-streets/" rel="prev"><span class="meta-nav">&larr;</span> COVID-19 and our local streets</a></div>
					<div class="nav-next"></div>
				</div><!-- #nav-above -->

				<div id="post-2122" class="post-2122 post type-post status-publish format-standard hentry category-audio category-technology tag-bluetooth tag-tp-link tag-ub400 tag-windows-10">
					<h1 class="entry-title">Fixing Bluetooth problem with TP-Link UB400</h1>

					<div class="entry-meta">
						<span class="meta-prep meta-prep-author">Posted on</span> <a href="https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/" title="4:28 pm" rel="bookmark"><span class="entry-date">June 28, 2020</span></a> <span class="meta-sep">by</span> <span class="author vcard"><a class="url fn n" href="https://www.martintod.org.uk/author/admin/" title="View all posts by Martin">Martin</a></span>					</div><!-- .entry-meta -->

					<div class="entry-content">
						<div class="socialize-in-content socialize-in-content-right"><div class="socialize-in-button socialize-in-button-right"><a href="http://twitter.com/share" class="twitter-share-button" data-url="https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/" data-text="Fixing Bluetooth problem with TP-Link UB400" data-count="vertical" data-via="mpntod" ><!--Tweetter--></a></div><div class="socialize-in-button socialize-in-button-right"><iframe src="//www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.martintod.org.uk%2F2020%2F06%2F28%2Ffixing-bluetooth-problem-with-tp-link-ub400%2F&amp;send=&amp;layout=box_count&amp;width=50&amp;show_faces=false&amp;action=like&amp;colorscheme=light&amp;font=arial&amp;height=65" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:50px; height:65px;" allowTransparency="true"></iframe></div></div>
<p>I recently bought myself some Sony Bluetooth earbuds for my phone, but I was keen to see if I could connect them to my PC too &#8211; so that I could use them in conference calls, for example.</p>



<p>But my computer didn&#8217;t have Bluetooth. So I bought TP-Link UB400 Bluetooth Adaptor online, because I&#8217;ve used and liked their stuff before.  But when I plugged it in it didn&#8217;t work!  Windows 10 kept telling me I didn&#8217;t have Bluetooth installed.</p>



<p>I went to the <a href="https://www.tp-link.com/uk/support/faq/2316/" class="aioseop-link">TP-Link FAQ</a> for the UB400 &#8211; but nothing they suggested worked.</p>



<p>After a bit of Googling, I went to the Windows Device Manager, looked at the Universal Serial Bus controllers, and disappeared down a rabbit hole trying to fix the &#8220;Unknown USB Device (Device Descriptor Request Failed)&#8221; problem.</p>



<p>And only then did I go to the &#8220;CSR Bluecore Bluetooth&#8221; driver that also appeared on the list of Universal Serial Bus controllers when I plugged in the dongle.  As an experiment:</p>



<ol><li>I right-clicked &#8220;CSR Bluecore Bluetooth and selected &#8220;Update driver&#8221;</li><li>Clicked on &#8220;Browse my computer for driver software&#8221;</li><li>Clicked on &#8220;Let me pick from a list of available drivers on my computer&#8221;</li><li>Picked &#8220;Generic Bluetooth Adaptor&#8221; in place of &#8220;CSR Bluecore Bluetooth&#8221;</li><li>Clicked &#8220;next&#8221;</li></ol>



<p>and suddenly everything worked!</p>



<p>So that&#8217;s my solution! I hope it works for you too.</p>
<div class="socialize-containter" style="background-color:#FFEAA8; border: 2px solid #ddd;"><div class="socialize-buttons"></div><div class="socialize-text">If you enjoyed this post, please consider <a href="#comments">leaving a comment</a> or <a href="http://www.martintod.org.uk/feed/" title="Syndicate this site using RSS">subscribing to the <abbr title="Really Simple Syndication">RSS</abbr> feed</a> to have future articles delivered to your feed reader.</div></div>											</div><!-- .entry-content -->

		
						<div class="entry-utility">
							This entry was posted in <a href="https://www.martintod.org.uk/category/audio/" rel="category tag">Audio</a>, <a href="https://www.martintod.org.uk/category/technology/" rel="category tag">Technology</a> and tagged <a href="https://www.martintod.org.uk/tag/bluetooth/" rel="tag">Bluetooth</a>, <a href="https://www.martintod.org.uk/tag/tp-link/" rel="tag">TP-Link</a>, <a href="https://www.martintod.org.uk/tag/ub400/" rel="tag">UB400</a>, <a href="https://www.martintod.org.uk/tag/windows-10/" rel="tag">Windows 10</a>. Bookmark the <a href="https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/" title="Permalink to Fixing Bluetooth problem with TP-Link UB400" rel="bookmark">permalink</a>.													</div><!-- .entry-utility -->
					</div><!-- #post-2122 -->

					<div id="nav-below" class="navigation">
						<div class="nav-previous"><a href="https://www.martintod.org.uk/2020/05/04/covid-19-and-our-local-streets/" rel="prev"><span class="meta-nav">&larr;</span> COVID-19 and our local streets</a></div>
						<div class="nav-next"></div>
					</div><!-- #nav-below -->

					
			<div id="comments">




	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Get in Touch <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+MartinTod+%28Martin+Tod%29#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.martintod.org.uk/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-postcode"><label for="postcode">Postcode</label><input id="postcode" name="postcode" type="text" value="" size="9" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='2122' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="1a6888ba49" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="192"/></p></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->

	
			</div><!-- #content -->
		</div><!-- #container -->


		<div id="primary" class="widget-area" role="complementary">
			<ul class="xoxo">

<li id="rotatingtweets_widget-3" class="widget-container widget_rotatingtweets_widget"><h3 class="widget-title">Martin&#8217;s Twitter</h3>
<div class='rotatingtweets rotatingtweets_format_0' id='rotatingtweets_4000_scrollUp_1000_5ef8e24002759' data-cycle-auto-height="calc" data-cycle-fx="scrollUp" data-cycle-pause-on-hover="true" data-cycle-timeout="4000" data-cycle-speed="1000" data-cycle-easing="swing" data-cycle-slides="div.rotatingtweet" data-cycle-log="false">
	<div class = 'rotatingtweet'>
		<p class='rtw_main'>Blog post: Fixing Bluetooth problem with TP-Link UB400 <a href='https://t.co/r7IRCP9CKj' title='https://goo.gl/fb/6VUqfU' class='rtw_url_link'>goo.gl/fb/6VUqfU</a></p>
		<p class='rtw_meta'><a  href="https://twitter.com/twitterapi/status/1277262708891627522">About 3 hours ago</a> from <a href='https://twitter.com/intent/user?screen_name=mpntod' title='Martin Tod'>Martin Tod's Twitter</a> via <a href="https://www.google.com/" rel="nofollow">Google</a> &middot; 
			<a href='https://twitter.com/intent/tweet?in_reply_to=1277262708891627522' title='reply' lang='en'>reply</a> &middot; 
			<a href='https://twitter.com/intent/retweet?tweet_id=1277262708891627522' title='retweet' lang='en'>retweet</a> &middot; 
			<a href='https://twitter.com/intent/favorite?tweet_id=1277262708891627522' title='favourite' lang='en'>favourite</a></p></div>
	<div class = 'rotatingtweet' style='display:none'>
		<p class='rtw_main'>Doesn't stack up. <a href='https://twitter.com/intent/user?screen_name=LibDems' title='Liberal Democrats' lang='en'>@LibDems</a> and Labour had their 1997 breakthrough when Paddy broke equidistance and Labour had an electable leader. Tories won their biggest recent majority when Labour diverted resource to fight LDs at the expense of fighting the Tories... <a href='https://t.co/2qD7QVA76N' title='https://twitter.com/NicholasTyrone/status/1275040284842360833' class='rtw_url_link'>twitter.com/NicholasTyrone…</a></p>
		<p class='rtw_meta'><a  href="https://twitter.com/twitterapi/status/1275157088323452928">About 6 days ago</a> from <a href='https://twitter.com/intent/user?screen_name=mpntod' title='Martin Tod'>Martin Tod's Twitter</a> via <a href="http://twitter.com/download/android" rel="nofollow">Twitter for Android</a> &middot; 
			<a href='https://twitter.com/intent/tweet?in_reply_to=1275157088323452928' title='reply' lang='en'>reply</a> &middot; 
			<a href='https://twitter.com/intent/retweet?tweet_id=1275157088323452928' title='retweet' lang='en'>retweet</a> &middot; 
			<a href='https://twitter.com/intent/favorite?tweet_id=1275157088323452928' title='favourite' lang='en'>favourite</a></p></div>
	<div class = 'rotatingtweet' style='display:none'>
		<p class='rtw_main'>Great initiative! <a href="https://twitter.com/search?q=%23StarTrekUnitedGives&amp;src=hash" title="#StarTrekUnitedGives" class="rtw_hashtag_link">#StarTrekUnitedGives</a> <a href='https://t.co/hmV4LNki7Q' title='https://twitter.com/jonathansfrakes/status/1273273848343994369' class='rtw_url_link'>twitter.com/jonathansfrake…</a></p>
		<p class='rtw_meta'><a  href="https://twitter.com/twitterapi/status/1273289847306883072">Last week</a> from <a href='https://twitter.com/intent/user?screen_name=mpntod' title='Martin Tod'>Martin Tod's Twitter</a> via <a href="https://mobile.twitter.com" rel="nofollow">Twitter Web App</a> &middot; 
			<a href='https://twitter.com/intent/tweet?in_reply_to=1273289847306883072' title='reply' lang='en'>reply</a> &middot; 
			<a href='https://twitter.com/intent/retweet?tweet_id=1273289847306883072' title='retweet' lang='en'>retweet</a> &middot; 
			<a href='https://twitter.com/intent/favorite?tweet_id=1273289847306883072' title='favourite' lang='en'>favourite</a></p></div>
	<div class = 'rotatingtweet' style='display:none'>
		<p class='rtw_main'>I'd missed that there was an online appeal to support the Licoricia of Winchester Statue Appeal. This would be such a positive thing for the city. Please donate. <a href='https://t.co/RgAT10c8hg' title='https://www.justgiving.com/campaign/licoricia?utm_term=2K17QcRAA&utm_source=twitter' class='rtw_url_link'>justgiving.com/campaign/licor&hellip;</a> ""</p>
		<p class='rtw_meta'><a  href="https://twitter.com/twitterapi/status/1272293601511460865">About 2 weeks ago</a> from <a href='https://twitter.com/intent/user?screen_name=mpntod' title='Martin Tod'>Martin Tod's Twitter</a> via <a href="https://mobile.twitter.com" rel="nofollow">Twitter Web App</a> &middot; 
			<a href='https://twitter.com/intent/tweet?in_reply_to=1272293601511460865' title='reply' lang='en'>reply</a> &middot; 
			<a href='https://twitter.com/intent/retweet?tweet_id=1272293601511460865' title='retweet' lang='en'>retweet</a> &middot; 
			<a href='https://twitter.com/intent/favorite?tweet_id=1272293601511460865' title='favourite' lang='en'>favourite</a></p></div>
</div>
<div class='rtw_follow follow-button'><a href='https://twitter.com/mpntod' class='twitter-follow-button' data-show-screen-name="false" title='Follow @mpntod' data-lang='en'>Follow @mpntod</a></div></li>              <li id="wm2_signup-6" class="widget-container widget_wm2_signup"><div class='wm2-support-enc'><h3 class="widget-title">Get local email news</h3><form id='wm2_signup-6-form' class='wm2-support-form'>
	<input value="Name" name="wm2_support_fullname" id="wm2_signup-6-fullname" type="text" size="25" class="wm2_support_input wm2_support_noentry wm2_support_fullwidth">
	<p id='wm2_signup-6_fullname_error' class='wm2_support_msg wm2_support_fullname_error' >This form doesn't allow special characters. Please re-enter your name or leave blank</p><input value="Email address" name="wm2_support_email" id="wm2_signup-6-email" type="text" size="25" class="wm2_support_input wm2_support_noentry wm2_support_fullwidth">
	<p id='wm2_signup-6_email_error' class='wm2_support_msg wm2_support_email_error' >Please enter a correct email</p><input value="Get local email news" name="wm2_support_title" id="wm2_signup-6-title" type="hidden" ><input value="martin@martintod.org.uk" name="wm2_support_to" id="wm2_signup-6-to" type="hidden" ><input value="Postcode" name="wm2_support_pcode" id="wm2_signup-6-pcode" type="text" size="8" maxlength="8" class="wm2_support_input wm2_support_noentry wm2_support_partwidth"><button class="wm2_support_submit" value="submitted" name="wm2_submit" type="submit">Sign up</button>
<img  class='wm2_support_msg wm2_support_waiting' src='https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/ajax-loader.gif' width='16' height='16' /><p id='wm2_signup-6_pcode_error' class='wm2_support_msg wm2_support_pcode_error' >Please enter a correct postcode or leave blank</p></form>
<p id='wm2_signup-6_success' class='wm2_support_msg wm2_support_thanks' >Thank you for signing up.</p></div></li>        <li id="feedburneremailwidget-2" class="widget-container FeedburnerEmailWidget"><h3 class="widget-title">Get latest posts by email</h3><form id="feedburner_email_widget_sbef" action="https://feedburner.google.com/fb/a/mailverify" method="post" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=martintod', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true;" target="popupwindow"><input id="feedburner_email_widget_sbef_email" name="email" type="text" /><input type="hidden" value="martintod" name="uri"/><input type="hidden" value="en_US" name="loc"/><input id="feedburner_email_widget_sbef_submit" type="submit" value="Subscribe" /><label>Delivered by <a href="https://feedburner.google.com" target="_blank">FeedBurner</a></label></form></li><li id="wid-show-wordtube-2" class="widget-container widget_wordtube"><h3 class="widget-title">WordTube</h3><div class="wordtube-widget"><div class="wordtube">
<div class="wordtube single45" id="WT1_1" style="width:200px; height:150px;">
<a href="http://www.macromedia.com/go/getflashplayer">Get the Flash Player</a> to see the wordTube Media Player.
</div></div>
	<script type="text/javascript" defer="defer">
var WT1_1 = {
	params : {
		wmode : "opaque",
		allowscriptaccess : "always",
		allownetworking : "all",
		allowfullscreen : "true"},
	flashvars : {
		streamer : "rtmp%3A%2F%2Fvideo.martintod.org.uk%2Fcfx%2Fst",
		file : "video%2FHousingWithoutInterruption.flv",
		volume : "80",
		bufferlength : "5",
		'logo.hide' : "false",
		skin : "%2Fwp-content%2Fuploads%2Fglow%2Fglow.xml",
		plugins : "viral-2,gapro-1",
		'gapro.accountid' : "UA-259652-9",
		image : "http%3A%2F%2Fcache.martintod.org.uk%2Fwp-content%2Fuploads%2F2012%2F10%2FHousing%2BDebate.png",
		title : "Lib%20Dem%20Housing%20Speech",
		linktarget : "_self"},
	attr : {
		id : "WT1",
		name : "WT1"},
	start : function() {
		swfobject.embedSWF("https://www.martintod.org.uk/wp-content/uploads/player.swf", "WT1_1", "200", "150", "9.0.0", false, this.flashvars, this.params , this.attr );
	}
}
WT1_1.start();
	</script>
</div></li><li id="text-5" class="widget-container widget_text"><h3 class="widget-title">Open Rights Group</h3>			<div class="textwidget"><a href="http://www.openrightsgroup.org/"><img src="http://widgets.openrightsgroup.org/founding1000/org-ftw/676315.png" alt="ORG FTW" /></a></div>
		</li><li id="wm2_youtubeplayer_widget-2" class="widget-container widget_wm2_youtubeplayer_widget"><h3 class="widget-title">YouTube videos</h3><!-- username = UC1i4TewfSh1UHz4wR6e : vidid = UxLZcimMTf4 -->
			<iframe width="200" height="175" src="https://www.youtube.com/embed/UxLZcimMTf4?fs=1&#038;origin=https%3A%2F%2Fwww.martintod.org.uk" frameborder="0" allowfullscreen></iframe>
		</li>        <li id="wm2_youtubeplayer_widget-3" class="widget-container widget_wm2_youtubeplayer_widget"><!-- username = UC1i4TewfSh1UHz4wR6e : vidid = oMJ1Ug2_5hU -->
			<iframe width="200" height="175" src="https://www.youtube.com/embed/oMJ1Ug2_5hU?fs=1&#038;origin=https%3A%2F%2Fwww.martintod.org.uk" frameborder="0" allowfullscreen></iframe>
		</li>        <li id="text-7" class="widget-container widget_text"><h3 class="widget-title">The Times cycling campaign</h3>			<div class="textwidget"><a href="http://thetim.es/cyclesafety"><img src="http://www.thetimes.co.uk/tto/multimedia/archive/00259/cycle_logo_259013a.png" alt="The Times Cities fit for cycling" width="140" height="140" border="0" /></a> </div>
		</li>			</ul>
		</div><!-- #primary .widget-area -->


		<div id="secondary" class="widget-area" role="complementary">
			<ul class="xoxo">
				<li id="rss-1" class="widget-container widget_rss"><h3 class="widget-title"><a class="rsswidget" href="http://www.flocktogether.org.uk/rss.php?Organisation=389&#038;sortorder=meetingdate"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://martintod.s3.amazonaws.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.flocktogether.org.uk/winchester">Upcoming meetings</a></h3><ul><li>An error has occurred, which probably means the feed is down. Try again later.</li></ul></li>			</ul>
		</div><!-- #secondary .widget-area -->

	</div><!-- #main -->

	<div id="footer" role="contentinfo">
		<div id="colophon">



			<div id="footer-widget-area" role="complementary">

				<div id="first" class="widget-area">
					<ul class="xoxo">
						<li id="nav_menu-3" class="widget-container widget_nav_menu"><h3 class="widget-title">Information</h3><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-835" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-835"><a href="https://www.martintod.org.uk/small-print/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-837" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-837"><a href="https://www.martintod.org.uk/contact-martin/">Contact</a></li>
</ul></div></li><li id="meta-2" class="widget-container widget_meta"><h3 class="widget-title">Administration</h3>			<ul>
						<li><a href="https://www.martintod.org.uk/wp-login.php">Log in</a></li>
			<li><a href="https://www.martintod.org.uk/feed/">Entries feed</a></li>
			<li><a href="https://www.martintod.org.uk/comments/feed/">Comments feed</a></li>
			<li><a href="https://en-gb.wordpress.org/">WordPress.org</a></li>			</ul>
			</li>					</ul>
				</div><!-- #first .widget-area -->

				<div id="second" class="widget-area">
					<ul class="xoxo">
						<li id="text-4" class="widget-container widget_text"><h3 class="widget-title">Twitter</h3>			<div class="textwidget"><a href="https://twitter.com/mpntod" class="twitter-follow-button" data-show-screen-name = "false" data-show-count="true">Follow @mpntod</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div>
		</li>              <li id="wm2_flickr-3" class="widget-container widget_wm2_flickr">                  <h3 class="widget-title">Flickr Gallery<img src="https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/profilmagazin/flickr1616.png" width="16" height="16" /></h3>
<a href="https://live.staticflickr.com/65535/50000789016_cee8e29577_z.jpg" rel="lightbox" title="Martin Tod backing #NotTheMassRide">
	<img src="https://live.staticflickr.com/65535/50000789016_cee8e29577_s.jpg" width="33" height="33" alt="Martin Tod backing #NotTheMassRide<br /><a href='https://www.flickr.com/photos/martin_tod/50000789016'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/65535/48695701286_eb78cddc35_z.jpg" rel="lightbox" title="Martin Tod with a pothole (and a plastic duck)">
	<img src="https://live.staticflickr.com/65535/48695701286_eb78cddc35_s.jpg" width="33" height="33" alt="Martin Tod with a pothole (and a plastic duck)<br /><a href='https://www.flickr.com/photos/martin_tod/48695701286'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/7895/46544582185_1173836c94_z.jpg" rel="lightbox" title="Lisbon">
	<img src="https://live.staticflickr.com/7895/46544582185_1173836c94_s.jpg" width="33" height="33" alt="Lisbon<br /><a href='https://www.flickr.com/photos/martin_tod/46544582185'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/7889/40493731723_63aacbc095_z.jpg" rel="lightbox" title="Flying angel">
	<img src="https://live.staticflickr.com/7889/40493731723_63aacbc095_s.jpg" width="33" height="33" alt="Flying angel<br /><a href='https://www.flickr.com/photos/martin_tod/40493731723'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/7918/40486169703_6091b0cef6_z.jpg" rel="lightbox" title="On the march">
	<img src="https://live.staticflickr.com/7918/40486169703_6091b0cef6_s.jpg" width="33" height="33" alt="On the march<br /><a href='https://www.flickr.com/photos/martin_tod/40486169703'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/7832/46536979395_e4bef41090_z.jpg" rel="lightbox" title="Winchester delegation - Put it to the People March">
	<img src="https://live.staticflickr.com/7832/46536979395_e4bef41090_s.jpg" width="33" height="33" alt="Winchester delegation - Put it to the People March<br /><a href='https://www.flickr.com/photos/martin_tod/46536979395'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/7818/47399204652_8c6441d9e6_z.jpg" rel="lightbox" title="Winchester delegation - Put it to the People March">
	<img src="https://live.staticflickr.com/7818/47399204652_8c6441d9e6_s.jpg" width="33" height="33" alt="Winchester delegation - Put it to the People March<br /><a href='https://www.flickr.com/photos/martin_tod/47399204652'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/7911/46536978765_13288f6b8b_z.jpg" rel="lightbox" title="Winchester delegation - Put it to the People March">
	<img src="https://live.staticflickr.com/7911/46536978765_13288f6b8b_s.jpg" width="33" height="33" alt="Winchester delegation - Put it to the People March<br /><a href='https://www.flickr.com/photos/martin_tod/46536978765'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/7864/32510422387_fb021277de_z.jpg" rel="lightbox" title="Neues Rathaus">
	<img src="https://live.staticflickr.com/7864/32510422387_fb021277de_s.jpg" width="33" height="33" alt="Neues Rathaus<br /><a href='https://www.flickr.com/photos/martin_tod/32510422387'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/7837/46729040544_f045e1cb21_z.jpg" rel="lightbox" title="Put it to the People March">
	<img src="https://live.staticflickr.com/7837/46729040544_f045e1cb21_s.jpg" width="33" height="33" alt="Put it to the People March<br /><a href='https://www.flickr.com/photos/martin_tod/46729040544'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/7913/32510422537_fcc6e54bdb_z.jpg" rel="lightbox" title="Winchester banner - Put it to the People March">
	<img src="https://live.staticflickr.com/7913/32510422537_fcc6e54bdb_s.jpg" width="33" height="33" alt="Winchester banner - Put it to the People March<br /><a href='https://www.flickr.com/photos/martin_tod/32510422537'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/7922/32510422757_984513f344_z.jpg" rel="lightbox" title="Winchester delegation - Put it to the People March">
	<img src="https://live.staticflickr.com/7922/32510422757_984513f344_s.jpg" width="33" height="33" alt="Winchester delegation - Put it to the People March<br /><a href='https://www.flickr.com/photos/martin_tod/32510422757'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/7841/47399194492_2c933708a9_z.jpg" rel="lightbox" title="Winchester delegation - Put it to the People March">
	<img src="https://live.staticflickr.com/7841/47399194492_2c933708a9_s.jpg" width="33" height="33" alt="Winchester delegation - Put it to the People March<br /><a href='https://www.flickr.com/photos/martin_tod/47399194492'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/4805/44448347190_9e85a6bb9d_z.jpg" rel="lightbox" title="Small Fangpa Castle at Yumen Pass">
	<img src="https://live.staticflickr.com/4805/44448347190_9e85a6bb9d_s.jpg" width="33" height="33" alt="Small Fangpa Castle at Yumen Pass<br /><a href='https://www.flickr.com/photos/martin_tod/44448347190'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/4904/45352729205_bbd928ff77_z.jpg" rel="lightbox" title="Detail of small Fangpa Castle at Yumen Pass">
	<img src="https://live.staticflickr.com/4904/45352729205_bbd928ff77_s.jpg" width="33" height="33" alt="Detail of small Fangpa Castle at Yumen Pass<br /><a href='https://www.flickr.com/photos/martin_tod/45352729205'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/4882/31326475157_d94c897eec_z.jpg" rel="lightbox" title="Great Wall at Yumen Pass">
	<img src="https://live.staticflickr.com/4882/31326475157_d94c897eec_s.jpg" width="33" height="33" alt="Great Wall at Yumen Pass<br /><a href='https://www.flickr.com/photos/martin_tod/31326475157'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/4823/46214966232_6417398ffe_z.jpg" rel="lightbox" title="Great Wall at Yumen Pass">
	<img src="https://live.staticflickr.com/4823/46214966232_6417398ffe_s.jpg" width="33" height="33" alt="Great Wall at Yumen Pass<br /><a href='https://www.flickr.com/photos/martin_tod/46214966232'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/1939/46214967322_b67179f837_z.jpg" rel="lightbox" title="Great Wall at Yumen Pass">
	<img src="https://live.staticflickr.com/1939/46214967322_b67179f837_s.jpg" width="33" height="33" alt="Great Wall at Yumen Pass<br /><a href='https://www.flickr.com/photos/martin_tod/46214967322'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/4842/46214968352_73568060af_z.jpg" rel="lightbox" title="Great Wall at Yumen Pass">
	<img src="https://live.staticflickr.com/4842/46214968352_73568060af_s.jpg" width="33" height="33" alt="Great Wall at Yumen Pass<br /><a href='https://www.flickr.com/photos/martin_tod/46214968352'>See original image on Flickr</a>"></a>

<a href="https://live.staticflickr.com/4871/46214969322_1146f7280e_z.jpg" rel="lightbox" title="Great Wall at Yumen Pass">
	<img src="https://live.staticflickr.com/4871/46214969322_1146f7280e_s.jpg" width="33" height="33" alt="Great Wall at Yumen Pass<br /><a href='https://www.flickr.com/photos/martin_tod/46214969322'>See original image on Flickr</a>"></a>
</li>        					</ul>
				</div><!-- #second .widget-area -->

				<div id="third" class="widget-area">
					<ul class="xoxo">
						<li id="search-3" class="widget-container widget_search"><h3 class="widget-title">Search</h3><form role="search" method="get" id="searchform" class="searchform" action="https://www.martintod.org.uk/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></li>              <li id="wm2_icons-3" class="widget-container widget_wm2_icons">                  <h3 class="widget-title">Find me</h3>
<a href="https://twitter.com/mpntod" title="twitter"><img src="https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/profilmagazin/twitter.png" alt="twitter" width="57" height="57"></a>
<a href="https://www.facebook.com/cllr.martin.tod" title="Facebook"><img src="https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/profilmagazin/facebook.png" alt="Facebook" width="57" height="57"></a>
<a href="https://www.youtube.com/user/UC1i4TewfSh1UHz4wR6e" title="YouTube"><img src="https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/profilmagazin/youtube.png" alt="YouTube" width="57" height="57"></a>
<a href="https://www.linkedin.com/in/martintod" title="Linkedin"><img src="https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/profilmagazin/linkedin.png" alt="Linkedin" width="57" height="57"></a>
<a href="https://www.flickr.com/photos/50317421@N00" title="flickr"><img src="https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/profilmagazin/flickr.png" alt="flickr" width="57" height="57"></a>
<a href="https://www.martintod.org.uk/feed/" title="RSS"><img src="https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/profilmagazin/rss.png" alt="RSS" width="57" height="57"></a></li>        					</ul>
				</div><!-- #third .widget-area -->

				<div id="fourth" class="widget-area">
					<ul class="xoxo">
						              <li id="wm2_signup-3" class="widget-container widget_wm2_signup"><div class='wm2-support-enc'><h3 class="widget-title">Get St Paul ward news</h3><form id='wm2_signup-3-form' class='wm2-support-form'>
	<input value="Name" name="wm2_support_fullname" id="wm2_signup-3-fullname" type="text" size="25" class="wm2_support_input wm2_support_noentry wm2_support_fullwidth">
	<p id='wm2_signup-3_fullname_error' class='wm2_support_msg wm2_support_fullname_error' >This form doesn't allow special characters. Please re-enter your name or leave blank</p><input value="Email address" name="wm2_support_email" id="wm2_signup-3-email" type="text" size="25" class="wm2_support_input wm2_support_noentry wm2_support_fullwidth">
	<p id='wm2_signup-3_email_error' class='wm2_support_msg wm2_support_email_error' >Please enter a correct email</p><input value="Get St Paul ward news" name="wm2_support_title" id="wm2_signup-3-title" type="hidden" ><input value="martin@martintod.org.uk" name="wm2_support_to" id="wm2_signup-3-to" type="hidden" ><input value="Postcode" name="wm2_support_pcode" id="wm2_signup-3-pcode" type="text" size="8" maxlength="8" class="wm2_support_input wm2_support_noentry wm2_support_partwidth"><button class="wm2_support_submit" value="submitted" name="wm2_submit" type="submit">Get news</button>
<img  class='wm2_support_msg wm2_support_waiting' src='https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/ajax-loader.gif' width='16' height='16' /><p id='wm2_signup-3_pcode_error' class='wm2_support_msg wm2_support_pcode_error' >Please enter a correct postcode or leave blank</p></form>
<p id='wm2_signup-3_success' class='wm2_support_msg wm2_support_thanks' >Thank you for signing up</p></div></li>        					</ul>
				</div><!-- #fourth .widget-area -->

			</div><!-- #footer-widget-area -->

			<div id="site-info">
					Hosted by <a href="http://www.1and1.co.uk/?k_id=9682658">1&amp;1 Internet Limited</a>, The Nova Building, Herschel Street, Slough, SL1 1XS. Published and promoted by Phryn Dickens on behalf of Martin Tod (Liberal Democrats), all at 107 Leigh Road, Eastleigh, SO50 9DR			</div><!-- #site-info -->

			<div id="site-generator">
								<a href="https://wordpress.org/"
						title="Semantic Personal Publishing Platform" rel="generator">
					Proudly powered by WordPress				</a> and the Winchester Marmalade theme by <a href="https://www.martintod.org.uk/" target="_blank">Martin Tod</a> and <a href="https://www.marmaladeontoast.co.uk/" target="_blank">Marmalade on Toast</a>.
			</div><!-- #site-generator -->

		</div><!-- #colophon -->
	</div><!-- #footer -->

</div><!-- #wrapper -->

<script type='text/javascript' src='http://platform.twitter.com/widgets.js?ver=ba93174f25df77d8829ca6586d356f70'></script>
<script type='text/javascript' src='https://martintod.s3.amazonaws.com/wp-includes/js/comment-reply.min.js.gzip?ver=ba93174f25df77d8829ca6586d356f70'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctcc_vars = {"expiry":"30","method":"1","version":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.martintod.org.uk/wp-content/plugins/uk-cookie-consent/assets/js/uk-cookie-consent-js.js?ver=2.3.0'></script>
<script type='text/javascript' src='https://martintod.s3.amazonaws.com/wp-includes/js/wp-embed.min.js.gzip?ver=ba93174f25df77d8829ca6586d356f70'></script>
<script async="async" type='text/javascript' src='https://www.martintod.org.uk/wp-content/plugins/akismet/_inc/form.js?ver=4.1.5'></script>
			
				<script type="text/javascript">
					jQuery(document).ready(function($){
												if(!catapultReadCookie("catAccCookies")){ // If the cookie has not been set then show the bar
							$("html").addClass("has-cookie-bar");
							$("html").addClass("cookie-bar-top-bar");
							$("html").addClass("cookie-bar-bar");
															// Wait for the animation on the html to end before recalculating the required top margin
								$("html").on('webkitTransitionEnd otransitionend oTransitionEnd msTransitionEnd transitionend', function(e) {
									// code to execute after transition ends
									var barHeight = $('#catapult-cookie-bar').outerHeight();
									$("html").css("margin-top",barHeight);
									$("body.admin-bar").css("margin-top",barHeight-32); // Push the body down if the admin bar is active
								});
													}
																	});
				</script>
			
			<div id="catapult-cookie-bar" class=""><div class="ctcc-inner "><span class="ctcc-left-side">This site uses cookies:  <a class="ctcc-more-info-link" tabindex=0 target="_blank" href="https://www.martintod.org.uk/2020/06/28/fixing-bluetooth-problem-with-tp-link-ub400/">Find out more.</a></span><span class="ctcc-right-side"><button id="catapultCookie" tabindex=0 onclick="catapultAcceptCookies();">Okay, thanks</button></span></div><!-- custom wrapper class --></div><!-- #catapult-cookie-bar --></body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Page Caching using disk 

Page cache debug info:
Engine:             disk
Cache key:          7d9473ece0768ac3f9ae0dd8ee981590_ssl
Creation Time:      1593369152.000s
Header info:
Content-Type:       text/html; charset=UTF-8
X-Clacks-Overhead:  GNU Terry Pratchett
X-Powered-By:       W3 Total Cache/0.13.3
X-Pingback:         https://www.martintod.org.uk/xmlrpc.php
Set-Cookie:         PHPSESSID=3c38ec9de40e8ddc3d95c12dbe7766f8; path=/
Expires:            Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control:      no-store, no-cache, must-revalidate
Pragma:             no-cache
Link:               <https://www.martintod.org.uk/wp-json/>; rel="https://api.w.org/"
Link:               <https://www.martintod.org.uk/?p=2122>; rel=shortlink

Content Delivery Network via Amazon Web Services: S3: martintod.s3.amazonaws.com
Replaced URLs for CDN:
https://www.martintod.org.uk/wp-content/uploads/wp-geo/markers/large-marker.png => https://martintod.s3.amazonaws.com/wp-content/uploads/wp-geo/markers/large-marker.png
https://www.martintod.org.uk/wp-content/uploads/wp-geo/markers/large-marker-shadow.png => https://martintod.s3.amazonaws.com/wp-content/uploads/wp-geo/markers/large-marker-shadow.png
https://www.martintod.org.uk/wp-content/uploads/wp-geo/markers/small-marker.png => https://martintod.s3.amazonaws.com/wp-content/uploads/wp-geo/markers/small-marker.png
https://www.martintod.org.uk/wp-content/uploads/wp-geo/markers/small-marker-shadow.png => https://martintod.s3.amazonaws.com/wp-content/uploads/wp-geo/markers/small-marker-shadow.png
https://www.martintod.org.uk/wp-content/uploads/wp-geo/markers/dot-marker.png => https://martintod.s3.amazonaws.com/wp-content/uploads/wp-geo/markers/dot-marker.png
https://www.martintod.org.uk/wp-content/uploads/wp-geo/markers/dot-marker-shadow.png => https://martintod.s3.amazonaws.com/wp-content/uploads/wp-geo/markers/dot-marker-shadow.png
https://www.martintod.org.uk/wp-content/uploads/2017/10/WebsiteMeonValleyPhoto1200630.jpg => https://martintod.s3.amazonaws.com/wp-content/uploads/2017/10/WebsiteMeonValleyPhoto1200630.jpg
https://www.martintod.org.uk/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp => https://martintod.s3.amazonaws.com/wp-includes/js/jquery/jquery.js.gzip?ver=1.12.4-wp
https://www.martintod.org.uk/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1 => https://martintod.s3.amazonaws.com/wp-includes/js/jquery/jquery-migrate.min.js.gzip?ver=1.4.1
https://www.martintod.org.uk/wp-includes/js/swfobject.js?ver=2.2-20120417 => https://martintod.s3.amazonaws.com/wp-includes/js/swfobject.js.gzip?ver=2.2-20120417
https://www.martintod.org.uk/wp-includes/images/rss.png => https://martintod.s3.amazonaws.com/wp-includes/images/rss.png
https://www.martintod.org.uk/wp-includes/js/comment-reply.min.js?ver=ba93174f25df77d8829ca6586d356f70 => https://martintod.s3.amazonaws.com/wp-includes/js/comment-reply.min.js.gzip?ver=ba93174f25df77d8829ca6586d356f70
https://www.martintod.org.uk/wp-includes/js/wp-embed.min.js?ver=ba93174f25df77d8829ca6586d356f70 => https://martintod.s3.amazonaws.com/wp-includes/js/wp-embed.min.js.gzip?ver=ba93174f25df77d8829ca6586d356f70
https://www.martintod.org.uk/wp-content/themes/winmarm2/js/wm2-support.js?ver=ba93174f25df77d8829ca6586d356f70 => https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/js/wm2-support.js.gzip?ver=ba93174f25df77d8829ca6586d356f70
https://www.martintod.org.uk/wp-content/themes/winmarm2/js/jquery.lightbox-0.5.min.js?ver=0.5 => https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/js/jquery.lightbox-0.5.min.js.gzip?ver=0.5
https://www.martintod.org.uk/wp-content/themes/winmarm2/js/wm2.lightbox.js?ver=ba93174f25df77d8829ca6586d356f70 => https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/js/wm2.lightbox.js.gzip?ver=ba93174f25df77d8829ca6586d356f70
https://www.martintod.org.uk/wp-content/themes/winmarm2/js/jquery.cycle.js?ver=2.22 => https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/js/jquery.cycle.js.gzip?ver=2.22
https://www.martintod.org.uk/wp-content/themes/winmarm2/js/wm.image.cycle.js?ver=1.0 => https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/js/wm.image.cycle.js.gzip?ver=1.0
https://www.martintod.org.uk/wp-content/themes/winmarm2/images/ldlogo.gif => https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/ldlogo.gif
https://www.martintod.org.uk/wp-content/themes/winmarm2/images/ajax-loader.gif => https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/ajax-loader.gif
https://www.martintod.org.uk/wp-content/themes/winmarm2/images/profilmagazin/flickr1616.png => https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/profilmagazin/flickr1616.png
https://www.martintod.org.uk/wp-content/themes/winmarm2/images/profilmagazin/twitter.png => https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/profilmagazin/twitter.png
https://www.martintod.org.uk/wp-content/themes/winmarm2/images/profilmagazin/facebook.png => https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/profilmagazin/facebook.png
https://www.martintod.org.uk/wp-content/themes/winmarm2/images/profilmagazin/youtube.png => https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/profilmagazin/youtube.png
https://www.martintod.org.uk/wp-content/themes/winmarm2/images/profilmagazin/linkedin.png => https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/profilmagazin/linkedin.png
https://www.martintod.org.uk/wp-content/themes/winmarm2/images/profilmagazin/flickr.png => https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/profilmagazin/flickr.png
https://www.martintod.org.uk/wp-content/themes/winmarm2/images/profilmagazin/rss.png => https://martintod.s3.amazonaws.com/wp-content/themes/winmarm2/images/profilmagazin/rss.png

Minified using disk

Minify debug info:
Theme:              d3e18
Template:           single

Database Caching 9/81 queries in 0.052 seconds using disk (Request-wide modification query)

Db cache debug info:
Total queries:      81
Cached queries:     9
Total query time:   0.0525

Served from: martintod.org.uk @ 2020-06-28 19:32:32 by W3 Total Cache
-->